Design & Build

Data Center Infrastructure-Deployment Guide: VCS Fabric Building Block with Cisco Nexus/UCS Switches

by Brook.Reams_1 on ‎06-28-2012 10:31 AM - edited on ‎04-04-2014 11:35 AM by Community Manager (219 Views)

Synopsis: Provides deployment configurations for Brocade's VCS Fabric and Brocade VDX Switches with Cisco Nexus 7000, UCS 6120 Fabric Interconnect, Nexus 5000 and Nexus 1000v switches.

 

Contents

 

 

Preface

 

Overview

Brocade VCS® Fabric eliminates STP while providing advanced features such as automatic fabric formation, automatic Brocade ISL Trunk formation, and equal cost multipath (ECMP) at layer-2. A VCS Fabric also supports single and multi-hop Fibre Channel over Ethernet (FCoE) and connectivity to existing Fibre Channel SANs.

 

Purpose of This Document

This document provides detailed configuration of a Brocade VCS Fabric with Cisco Nexus 7000, UCS 6120 Fabric Interconnect, Nexus 5000 and Nexus 1000v switches.

 

Audience

Network architects, designers and administrators will find useful information about configuration and deployment of VCS Fabric with Cisco Nexus products.

 

Objectives

The network edge, or access layer, is subject to several significant changes including server virtualization, 10 GE adoption (at the switch and in the server), converged networking (IP + Storage traffic) with Ethernet Data Center Bridging (DCB). New technologies, such as Ethernet Fabrics, have been introduced to address limitations in Ethernet networks. Brocade VCS Fabric is Brocade’s implementation of an Ethernet Fabric and includes a number of powerful extensions such as virtual LAG (vLAG), automatic fabric formation, and automatic Brocade ISL Trunk formation.

 

A VCS Fabric does not use spanning tree protocol (STP) to prevent loops relying instead on link state routing at layer-2. It can be configured as a transparent LAN allowing STP BPDU frames to flow between switches using STP (such as Cisco Nexus switches). In this way, STP switches connected to a VCS Fabric can negotiate the root bridge and select the least cost path to the root bridge in the tree.

 

Related Documents

Brocade’s VCS Fabric is one of many building blocks in the Data Center Infrastructure Baseline Reference Architecture. This deployment guide provides validated configuration information for constructing a VCS Fabric building block when connecting it to Cisco Nexus switches and Cisco UCS Fabric Interconnects.

 

References

 

About Brocade

Brocade® (NASDAQ: BRCD) networking solutions help the world’s leading organizations transition smoothly to a world where applications and information reside anywhere. This vision is designed to deliver key business benefits such as unmatched simplicity, non-stop networking, application optimization, and investment protection.

 

Innovative Ethernet and storage networking solutions for data center, campus, and service provider networks help reduce complexity and cost while enabling virtualization and cloud computing to increase business agility.

 

To help ensure a complete solution, Brocade partners with world-class IT companies and provides comprehensive education, support, and professional services offerings. (www.brocade.com)

 

Key Contributors

The content in this guide was provided by the following key contributors.

    • Lead Engineer: Michael O'Conner, Strategic Solutions Lab

 

Document History

Date                  Version        Description

2012-06-29       1.0                  Initial Release

2012-07-12       1.1                  Edit graphics for better PDF display/print

 

 

Technical Architecture

The following Brocade VCS Fabric configurations are provided in this guide:

 

The topology used for many of the configurations has a simple two switch VCS Fabric. Although a VCS Fabric can contain many more switches than this, a simpler VCS Fabric configuration is used to avoid distraction from the fundamentals.

 

There are video demonstrations in English, Spanish and French, showing how simple it is to create a VCS Fabric and configure several useful features.

 

References

 

Configuring VCS Fabric with Cisco Nexus 7000

This configuration uses a VCS Fabric with two VDX 6720 switches connected to a Cisco Nexus 7000 and sFlow monitoring.

 

Topology

The diagram below shows the deployment topology.

DataCenter-Infrastructure_DG_2VDX&Nexus7K.JPG

   Deployment Topology (click to enlarge)

 

Pre-requisites

1.   You should have all necessary software licenses available and installed on the switches. For instance, if you are creating a VCS Fabric with more than two VDX switches, you will need to install the VCS Fabric license on each switch. License installation steps are not covered in this guide.

2.   All switches and servers should be unpacked, racked, and power and network cable pulled and available before you begin the deployment.

3.   Any specific VLAN and IP addresses you need for your environment should be available.

 

Bill of Materials

The following products are used in this deployment.

 

Identifier

Vendor

Model

Notes

Callisto_24

Brocade

VDX 6720-24

 

Callisto_31

Brocade

VDX 6720-24

 

Nexus7000-DC-1

Cisco

Nexus 7000

 

 

Task 1: Configure the VCS Fabric

Description

This task configures the VCS Fabric using two VDX 6720-24 switches. A VCS Fabric automatically forms when the VDX switches are in VCS mode and a cable connects two VDX switches. The ports are called Fabric ports. It is best practice to have a minimum of two Fabric ports between VDX switches for resiliency and high availability.

 

To connect the VCS Fabric to the Nexus 7000, a VCS Fabric vLAG is created spanning both VDX 6720 switches. VDX switch ports not connected to another VDX switch in the same fabric are called Edge ports. A vLAG can be configured on Edge ports but not Fabric ports.  The other end of the vLAG links terminate on the Nexus 7000 which sees these links as part of the same layer-2 LACP-based port channel.

 

Assumptions

1.   A PC has been configured as an sFlow collector to gather traffic information from the VCS Fabric (all VDX switches).

2.   Each VDX switch has been assigned a unique RBridge ID.

 

Step 1: Connect VDX Switches Together

Connect both VDX switches with at least two 10GE links. The switches are connected via a VCS Fabric ISL using ports 9 and 10 on each VDX switch which automatically creates a two switch VCS Fabric and a two ISL Brocade ISL Trunk.

-----

interface TenGigabitEthernet 31/0/9

description "fabric isl connection to VDX-2"

fabric isl enable

fabric trunk enable

no shutdown

-----

 

Note:

The “description” command above is not needed to make this work, but it is best practice to document what interfaces are used for Fabric ports and aids troubleshooting.

 

Step 2: Enable VCS Fabric Mode

To enable VCS mode on each of the VDX switches, you use the following command:

-----

Callisto_24# vcs rbridgeid 24 enable

-----

 

The switch reboots when you confirm that you want to enable VCS mode. Then on the other VDX, you will run the same command rbridgeid number to match the rbridgeid of that VDX switch (31).

 

Confirm the VCS Fabric Formed

Enter the following command on either VDX switch to confirm the VCS Fabric formed. Look for the state to show “Enabled”.

-----

Callisto_24# sh vcs

state      : Enabled

vcsid      : 1

rbridgeid  : 24

-----

 

Then, issue this command to confirm the size of the VCS Fabric.

-----

Callisto_24# sh fabric all

 

VCS Id: 1   (The id that’s used here is the factory default and can be changed if needed)

VCS Mode: Fabric Cluster

 

RBridge-ID           WWN                     IP Address           Name

----------------------------------------------------------------------------

24         10:00:00:05:1E:CD:5F:EA          10.18.232.96       >"Callisto_24"

31         10:00:00:05:33:41:1B:B7          10.18.232.97        "Callisto_31"

-----

 

The Fabric has 2 RBridge(s), 24 and 31.

 

For more information about enabling VCS mode and VCS Fabric configuration, see the following references.

 

References

 

Step 3: Configure vLAG on VDX Edge Ports

In this step, a four-port vLAG is configured with two links of the vLAG on Edge ports on each VDX 6720 switch. All four links are in a single VCS Fabric vLAG and terminate at the Nexus 7000.

 

On Callisto-24 enter the following commands.

-----

interface TenGigabitEthernet 24/0/1

fabric isl enable

fabric trunk enable

channel-group 20 mode active type standard 

lacp timeout long <--NOS inserts this line by default

no shutdown

!

interface TenGigabitEthernet 24/0/21

fabric isl enable

fabric trunk enable

channel-group 20 mode active type standard

lacp timeout long

no shutdown

!

interface Port channel 20

description port channel 20 connection to Nexus 7000

switchport

switchport mode access

switchport access vlan 1 <--NOS inserts this line by default

no shutdown

-----

 

The channel-group 20 option indicates this Edge port interface is part of a vLAG with port channel 20.

Similarly on Callisto-31, enter the following commands.

-----

interface TenGigabitEthernet 31/0/1

fabric isl enable

fabric trunk enable

channel-group 20 mode active type standard

lacp timeout long

no shutdown

!

interface TenGigabitEthernet 31/0/21

fabric isl enable

fabric trunk enable

channel-group 20 mode active type standard

lacp timeout long

no shutdown

!

interface Port channel 20

description port channel 20 connection to Nexus 7000

switchport

switchport mode access

switchport access vlan 1

no shutdown

-----

 

Step 4: Configure sFlow Monitoring for VCS Fabric

The following commands enable sFlow monitoring for all switches in the VCS Fabric using the default port-profile.

-----

port-profile default

sflow enable

sflow collector 10.20.63.181

sflow polling-interval 5

sflow sample-rate 1000

-----

 

TIP --> Configuring Fabric ISL and Brocade ISL Trunks

Callisto_24# show fabric trunk

 

RBridge-ID: 24

 

Group   Src-Port        Nbr-Port                Nbr-WWN

------------------------------------------------------------------------

1      Te 24/0/9       Te 31/0/9       10:00:00:05:33:3F:smileyvery-happy:4:B8

2      Te 24/0/13      Te 31/0/13      10:00:00:05:33:3F:smileyvery-happy:4:B8

-----

 

Callisto_24# show fabric isl

RBridge-ID: 24   #ISLs: 2

 

Src-Port       Nbr-Port                Nbr-WWN          BW  Trunk    Nbr-Name

--------------------------------------------------------------------------------

Te 24/0/9      Te 31/0/9      10:00:00:05:33:3F:smileyvery-happy:4:B8   10G  Yes    "Callisto_31"

Te 24/0/13     Te 31/0/13     10:00:00:05:33:3F:smileyvery-happy:4:B8   10G  Yes    "Callisto_31"

-----

Callisto_24# show fabric trunk

 

RBridge-ID: 24

 

Group   Src-Port        Nbr-Port                Nbr-WWN

------------------------------------------------------------------------

1      Te 24/0/9      Te 31/0/9      10:00:00:05:33:3F:smileyvery-happy:4:B8

1      Te 24/0/10     Te 31/0/10     10:00:00:05:33:3F:smileyvery-happy:4:B8

-----

 

Callisto_24# sh fabric isl

 

RBridge-ID: 24   #ISLs: 1

 

Src-Port      Nbr-Port       Nbr-WWN                    BW   Trunk   Nbr-Name

----------------------------------------------------------------------------------

Te 24/0/9      Te 31/0/9      10:00:00:05:33:3F:smileyvery-happy:4:B8    20G  Yes    "Callisto_31"

-----

 

Task 2: Configure the Nexus 7000 Port Channel

Description

In this task, a four port, port channel is configured on the Nexus 7000. Two links in the port channel go to Edge ports on each of the VDX 6720 switches and all four links are part of the same VCS Fabric vLAG.

 

Assumptions

1.   The Nexus 7000 has been unpacked, racked and installed and is correctly operating.

 

Step 1: Configure Nexus 7000 Port Channel

Configure the four ports in the port channel using the following commands with the interfaces on the Nexus 7000 you want to include in this port channel (shown as 1/1 – 4).

-----

Nexus7000-DC-1(config)# feature lacp

Nexus7000-DC-1(config)# interface port channel 1

Nexus7000-DC-1(config-if)# shutdown

Nexus7000-DC-1(config)# int ethernet 1/1 - 4

Nexus7000-DC-1(config-if-range)# channel-group 1 mode active    

-----

 

Use the following command to confirm the port channel configuration on the Nexus 7000.

------

Nexus7000-DC-1# sh run

 

feature lacp

……

interface port channel1

shutdown

 

interface Ethernet1/1

  channel-group 1 mode active   <--connected to VDX-1

interface Ethernet1/2

  channel-group 1 mode active   <--connected to VDX-1

interface Ethernet1/3

  channel-group 1 mode active   <--connected to VDX-1

interface Ethernet1/4

  channel-group 1 mode active   <--connected to VDX-1

-----

 

Note:

Notice the interface is put in shutdown mode before configuring the port channel. This avoids any issues when configuring the interfaces.

 

Confirm the VCS Fabric vLAG and Nexus 7000 Port Channel Configurations

Use the following commands on VDX-1 to confirm the vLAG is running correctly.

-----

Callisto_24# show port channel summary

LACP Aggregator: Po 20 (vLAG)   <--(1) Confirm vLAG displays

Aggregator type: Standard

  Member switches:

    RBridge-ID: 24 (2)

    RBridge-ID: 31 (2)

  Admin Key: 0020 - Oper Key 0020

   Link: Te 24/0/1 (0x18010000) sync: 1

   Link: Te 24/0/21 (0x18150014) sync: 1

 

Callisto_24# show port channel detail

LACP Aggregator: Po 20 (vLAG)   <--(1) Confirm vLAG displays

Aggregator type: Standard

  Member switches:

    RBridge-ID: 24 (1)

    RBridge-ID: 31 (1)

  Actor System ID - 0x8000,01-e0-52-00-00-01

  Admin Key: 0020 - Oper Key 0020

  Receive link count: 1 - Transmit link count: 1

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-22-55-79-e0-c2

  Partner Oper Key 0000

   Link: Te 24/0/1 (0x18010000) sync: 1

-----

 

Use the following commands on VDX-2 to confirm the vLAG is operating correctly.

-----

Callisto_31# show port channel summary

LACP Aggregator: Po 20 (vLAG)

Aggregator type: Standard

  Member switches:

    RBridge-ID: 24 (2)

    RBridge-ID: 31 (2)

  Admin Key: 0020 - Oper Key 0020

   Link: Te 31/0/1 (0x18010000) sync:

   Link: Te 31/0/21 (0x18150200) sync: 1   *   <--(2) Note the “*” on this line

Callisto_31# show port channel detail

LACP Aggregator: Po 20 (vLAG)

Aggregator type: Standard

  Member switches:

    RBridge-ID: 24 (2)

    RBridge-ID: 31 (2)

  Actor System ID - 0x8000,01-e0-52-00-00-01

  Admin Key: 0020 - Oper Key 0020

  Receive link count: 2 - Transmit link count: 2

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-22-55-79-e0-c2

  Partner Oper Key 0000

   Link: Te 31/0/1 (0x18010000) sync: 1

   Link: Te 31/0/21 (0x18150200) sync: 1   *

-----

 

Notes:

          1. If you don’t see (vLAG) in the output, check the port configuration and cables for any problems.
          2. The “*” indicates the master link for the port channel and the 31/0/21 indicates it is on RBridge 31, port 21.

 

Use the following command on the Nexus 7000 to confirm the port channel configuration.

-----

Nexus7000-DC-1# sh port channel summary

 

Flags:  D - Down                    P - Up in port channel (members)

            I - Individual          H - Hot-standby (LACP only)

            s - Suspended           r - Module-removed

            S - Switched            R - Routed

            U - Up (port channel)

--------------------------------------------------------------------------------

Group Port-       Type     Protocol  Member Ports

      Channel

--------------------------------------------------------------------------------

1     Po1(SU)     Eth      LACP      Eth1/1(P)    Eth1/2(P)    Eth1/3(P)

                                                     Eth1/4(P)

-----

 

Use the following command on the Nexus 7000 to confirm traffic is flowing on the port channel.

-----

Nexus7000-DC-1# sh port channel traffic

ChanId Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst

------ --------- ------- ------- ------- ------- ------- -------

     1    Eth1/1    0.0%    0.0%  25.59%   9.26%    0.0%    0.0%

     1    Eth1/2    0.0%    0.0%  25.00%  71.88%   0.0%    0.0%

     1    Eth1/3    0.0%    0.0%  23.80%   9.90%    0.0%    0.0%

     1    Eth1/4    0.0%    0.0%  25.59%   8.94%    0.0%    0.0%

-----

 

This shows a four port layer-2 port channel on the Nexus 7000 has connected to the VCS Fabric vLAG using LACP protocol.

 

Configuring VCS Fabric with Cisco Nexus 1000v

The deployment covers configuration of a VCS Fabric with two VDX 6720 switches and a Cisco Nexus 1000v.

 

Topology

The diagram below shows the deployment topology.

DataCenter-Infrastructure_DG_2VDX&Nexus1000v.JPG

   Deployment Topology (click to enlarge)

 

Pre-requisites

        1. You should have all necessary software licenses available and installed on the switches. For instance, if you are creating a VCS Fabric with more than two VDX switches, you will need to install the VCS Fabric license on each switch. License installation steps are not covered in this guide.
        2. All switches and servers should be unpacked, racked, and power and network cable pulled and available before you begin the deployment.
        3. Any specific VLAN and IP addresses you need for your environment should be available.

 

Bill of Materials

The following products are used in this deployment.

 

Identifier

Vendor

Model

Notes

Callisto_24

Brocade

VDX 6720-60

 

Callisto_31

Brocade

VDX 6720-60

 

Nexus1000-DC-1

Cisco

Nexus 1000v “softswitch”

 

 

Task 1: Configure the VCS Fabric

Description

In this configuration, we create a VCS Fabric using two VDX 6720 switches. We then connect the VCS Fabric to a Nexus 1000v. The VCS Fabric configuration steps are the same as described in Configuring VCS Fabric with Nexus 7000, so only links to those steps are provided in this configuration The VCS Fabric vLAG now connects to a port channel configured on the Nexus 1000v switch.

 

Assumptions

        1. The VDX 6720 switches have been installed and are operating correctly.

 

Step 1: Connect VDX Switches Together <![if !supportNestedAnchors]> <![endif]>

 

Step 2: Enable VCS Fabric Mode <![if !supportNestedAnchors]> <![endif]>

 

Step 3: Configure vLAG on VDX Edge Ports <![if !supportNestedAnchors]> <![endif]>

 

Step 4: Configure sFlow Monitoring for VCS Fabric <![if !supportNestedAnchors]> <![endif]>

 

Task 2: Configure the Nexus 1000v Port Channel

Description

In this task, a four port, port channel is configured on the Nexus 1000v. Two links in the port channel go to Edge ports on each of the VDX 6720 switches and all four links are part of the same VCS Fabric vLAG.

 

Assumptions

        1. The Nexus 1000v software has been installed in the Hypervisor and is correctly operating.

 

Step 1: Configure Nexus 1000v Port Channel

Use the following commands to create a port channel interface on the Nexus 1000v.

-----

config t

interface port channel 100

shutdown

show port channel summary

copy running-config startup-config

-----

 

Step 2: Add Nexus 1000v Interfaces to the Port Channel

Use the following commands to add layer-2 interfaces on the Nexus 1000v to the  port channel.

-----

config t

interface 1/1 – 4

switchport

channel-group 100 mode active

interface port channel 100

no shutdown

show port channel summary

copy running-config startup-config

-----

 

Note:

Depending on your environment, there could some required changes to the Nexus 1000v configuration. See the following url’s for more information.

 

References

 

Configuring VCS Fabric with Cisco UCS 6120 Fabric Interconnect

In this configuration, we create a VCS Fabric using two VDX 6720 switches. We then connect the VCS Fabric to a Cisco UCS 5108 with the UCS 6120 Fabric Interconnect (FI) module. The VCS Fabric vLAG now connects to a port channel configured on the UCS 6120 FI module.

 

Topology

The diagram below shows the deployment topology.

DataCenter-Infrastructure_DG_2VDX&Nexus6120.JPG

   Deployment Topology (click to enlarge)

 

Pre-requisites

        1. You should have all necessary software licenses available and installed on the switches. For instance, if you are creating a VCS Fabric with more than two VDX switches, you will need to install the VCS Fabric license on each switch. License installation steps are not covered in this guide.
        2. All switches and servers should be unpacked, racked, and power and network cable pulled and available before you begin the deployment.
        3. Any specific VLAN and IP addresses you need for your environment should be available.

 

Bill of Materials

The following products are used in this deployment.

 

Identifier

Vendor

Model

Notes

Callisto_24

Brocade

VDX 6720/24

 

Callisto_31

Brocade

VDX 6720/24

 

Nexus6120-DC-1

Cisco

Nexus UCS 6120

 

UCS5108-1

Cisco

UCS 5108 Blade Server

 

 

Task 1: Configure the VCS Fabric

Description

The VCS Fabric configuration steps are the same as described in Configuring VCS Fabric with Nexus 7000, so only links to those steps are provided in this configuration.

 

Assumptions

        1. The Cisco UCS 5108 chassis and UCS 6120 FI module have been installed and are operating correctly.

 

Step 1: Connect VDX Switches Together <![if !supportNestedAnchors]> <![endif]>

 

Step 2: Enable VCS Fabric Mode <![if !supportNestedAnchors]> <![endif]>

 

Step 3: Configure vLAG on VDX Edge Ports <![if !supportNestedAnchors]> <![endif]>

 

Step 4: Configure sFlow Monitoring for VCS Fabric <![if !supportNestedAnchors]> <![endif]>

 

Task 2: Configure the UCS 6120 Port Channel

Description

When a port channel is created on the UCS 6120 FI it automatically becomes an “uplink” port which is a special UCS port type. Four UCS 6120 FI ports are assigned to this port channel.  Finally the layer-2 LACP based port channel is created which is connected to the VCS Fabric vLAG.

 

It is best practice to configure two UCS 6120 FI port channels and two VCS Fabric vLAG for resiliency and high availability. A second port channel, 112 connecting to another vLAG channel-group 21 is shown as a note on the topology diagram, but the configuration steps are omitted for brevity.

Assumptions

        1. The UCS servers and UCS 6120 Fabric Interconnect are installed and operating correctly.

 

Step 1: Configure Port Channel on UCS 6120

Use the Cisco UCS System Manager to configure the UCS 6120 port channel. , we can see the port channel configured from one of our FI’s to our VCS Fabric as shown below.

 

DataCenter-Infrastructure_DG_2VDX&Nexus6120-UCSMngrDisplay.JPG

   Cisco UCS Manager Display (click to enlarge)

 

Note:

The “ID: 111” in the Properties box indicates the UCS 6120 port channel number.

 

Configuring VCS Fabric For Cisco Nexus Switches Using Spanning Tree

This deployment includes a two switch VCS Fabric connected to a Nexus 7000 and Nexus 5000 switch. The Nexus switches use spanning tree protocol, specifically rapid spanning tree (RSTP). This configuration shows how to make a VCS Fabric a “transparent LAN” so BPDU are passed through the VCS Fabric to other switches configured to spanning tree. In this way, switches with interfaces configured with spanning tree receive BPDU, elect a root bridge and eliminate loops in the topology.

 

Topology

The diagram below shows the deployment topology.

DataCenter-Infrastructure_DG_2VDX&Nexus7000+5000STP.JPG

   Deployment Topology (click to enlarge)

 

Pre-requisites

        1. You should have all necessary software licenses available and installed on the switches. For instance, if you are creating a VCS Fabric with more than two VDX switches, you will need to install the VCS Fabric license on each switch. License installation steps are not covered in this guide.
        2. All switches and servers should be unpacked, racked, and power and network cable pulled and available before you begin the deployment.
        3. Any specific VLAN and IP addresses you need for your environment should be available.

 

Bill of Materials

The following products are used in this deployment.

 

Identifier

Vendor

Model

Notes

Callisto_24

Brocade

VDX 6720-60

 

Callisto_31

Brocade

VDX 6720-60

 

Nexus7000-DC-1

Cisco

Nexus 7000

 

Nexus5K

Cisco

Nexus 5000

 

 

Task 1: Configure the VCS Fabric

Description

In this configuration, we create a VCS Fabric using two VDX 6720 switches. We then connect the VCS Fabric to a Nexus 7000 and 5000 switch running rapid spanning tree (rstp). The VCS Fabric configuration steps are the same as described in Configuring VCS Fabric with Nexus 7000, so only links to those steps are provided in this configuration The VCS Fabric vLAGs now connects to a port channel configured on each of the Nexus switches.

 

Assumptions

        1. The VDX 6720 switches have been installed and are operating correctly.

 

Step 1: Connect VDX Switches Together <![if !supportNestedAnchors]> <![endif]>

 

Step 2: Enable VCS Fabric Mode <![if !supportNestedAnchors]> <![endif]>

 

Step 3: Configure vLAG on VDX Edge Ports <![if !supportNestedAnchors]> <![endif]>

In this configuration, only use two links for the vLAG that will go the Nexus 7000 port channel being sure each link comes from one of the VDX 6720 switches.

 

Using the procedure in Step 3, create another two port vLAG that will connect to the Nexus 5000 switch so each port is on a separate VDX 6720 switch.

The following shows the final configuration of this second vLAG.

-----

Callisto_24# show port channel detail

LACP Aggregator: Po 2 (vLAG)

Aggregator type: Standard

  Member switches:

    RBridge-ID: 24 (1)

    RBridge-ID: 31 (1)

  Actor System ID - 0x8000,01-e0-52-00-00-01

  Admin Key: 0002 - Oper Key 0002

  Receive link count: 1 - Transmit link count: 1

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-0d-ec-a4-62-7c

  Partner Oper Key 0099

   Link: Te 24/0/2 (0x18020001) sync: 1

 

Callisto_31# show port channel detail

LACP Aggregator: Po 2 (vLAG)

Aggregator type: Standard

  Member switches:

    RBridge-ID: 24 (1)

    RBridge-ID: 31 (1)

  Actor System ID - 0x8000,01-e0-52-00-00-01

  Admin Key: 0002 - Oper Key 0002

  Receive link count: 1 - Transmit link count: 1

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-0d-ec-a4-62-7c

  Partner Oper Key 0099

   Link: Te 31/0/2 (0x18020001) sync: 1   *

-----

 

Step 4: Configure sFlow Monitoring for VCS Fabric <![if !supportNestedAnchors]> <![endif]>

 

Step 5: Configure VDX 6720 Edge Ports for Transparent LAN

On each VDX switch, under the interface for port channel 2 which connects to the Nexus 5000, shut it down and add in the following options in bold:

-----

interface Port channel 2

shutdown

switchport

switchport mode access

switchport access vlan 1

no shutdown

-----

 

The switchport command settings ensure BDPU are transparently passed through the VCS Fabric for VLAN 1 on port channel 2.

Enter the same commands on each VDX switch for port channel 20 which connects to the Nexus 7000.

-----

interface Port channel 20

shutdown

switchport

switchport mode access

switchport access vlan 1

no shutdown

-----

 

Step 6: Configure sFlow Monitoring for VCS Fabric <![if !supportNestedAnchors]> <![endif]>

 

Task 2: Configure the Nexus 7000 Port Channel.

Description

The Nexus 7000 configuration steps are the same as described in Configure the Nexus 7000 Port Channel, the steps link back to the previous configuration procedure. However, only two links are used on the Nexus 7000 to connect to the two link VCS Fabric vLAG.

 

Assumptions

        1. The Nexus 7000 switch has been installed and is operating correctly.

 

Step 1: Configure Nexus 7000 Port Channel

Only use two ports for the port channel being sure they connect to the VCS Fabric vLAG for the Nexus 7000 switch.

 

Task 3: Configure the Nexus 5000 Port Channel

Description

The Nexus 5000 configuration uses a two port, port channel that connects to the VCS Fabric vLAG for the Nexus 5000 switch.

 

Assumptions

        1. The Nexus 5000 switch has been installed and is operating correctly.

 

Step 1: Configure Nexus 5000 Port Channel

On the Nexus 5000, configure a two port, port channel with both links going to the VCS Fabric vLAGs for the Nexus 5000.

-----

Nexus5k# sh port channel summary

Flags:  D - Down        P - Up in port channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        S - Switched    R - Routed

        U - Up (port channel)

--------------------------------------------------------------------------------

Group Port- Type     Protocol  Member Ports

      Channel

--------------------------------------------------------------------------------

100   Po100(SU)   Eth LACP      Eth1/35(P)   Eth1/36(P)

-----

 

Confirm Nexus 7000 and 5000 Port Channel Configuration

From the Nexus 7000 we set the STP priority to a low value to force it to become the root bridge as shown below.

-----

Nexus7000-DC-1(config)# sh spanning-tree

 

VLAN0001

  Spanning tree enabled protocol rstp

  Root ID    Priority 4097 (This number is the priority 4096 + sys-id-ext 1 of VLAN1)

             Address     0022.5579.e0c2

             This bridge is the root   <--Root bridge for VLAN 1

             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

 

 

  Bridge ID  Priority    4097   (priority 4096 sys-id-ext 1)

             Address     0022.5579.e0c2

             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

 

 

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ----   --- --------- -------- --------------------------------

Po1               Desg FWD 1         128.4096 P2p

-----

 

From the Nexus 5000, use the same command to check on the spanning tree configuration.

-----

Nexus5k(config)# sh spanning-tree

 

VLAN0001

  Spanning tree enabled protocol rstp

  Root ID    Priority 4097

Address     0022.5579.e0c2 (MAC address from the Nexus 7000)

Cost        1

Port        4195 (port channel100)

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

 

  Bridge ID  Priority 28673  (priority 28672 sys-id-ext 1)

Address     000d.eca4.627c 

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

 

Interface Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Po100 Root FWD 1         128.4195 P2p

-----

 

The edge Nexus switches attached to the VCS Fabric are handling STP correctly since the VCS Fabric is transparent to STP BPDU’s acting like a “wire” between the edge Nexus switches. They are able to negotiate which one will be the root bridge and ensure one a single path connects them through the VCS Fabric to eliminate forwarding loops.

 

TIP --> What Does VDX switchport access mode Do?

-----

Nexus5k# sh spanning-tree

 

VLAN0001

  Spanning tree enabled protocol rstp

  Root ID    Priority    32769

             Address     000d.eca4.627c

             This bridge is the root   ß Shows Nexus 5000 is the root bridge

             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

 

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

             Address     000d.eca4.627c

             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

 

Interface        Role  Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Po100            Desg FWD 1         128.4195 P2p

-----

 

Nexus7000-DC-1# sh spanning-tree

 

VLAN0001

  Spanning tree enabled protocol rstp

  Root ID    Priority    32769

             Address     0022.5579.e0c2

             This bridge is the root   ß Shows Nexus 7000 is the root bridge

             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

 

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

             Address     0022.5579.e0c2

             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

 

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Po1              Desg FWD 1         128.4096 P2p

-----