Design & Build

Data Center Infrastructure-Best Practice: Configuring Cisco IP Helper with Brocade VCS Fabric and VDX Switches

by on ‎04-03-2013 07:43 AM - edited on ‎04-08-2014 01:50 PM by pmadduru (1,129 Views)

Synopsis: An example showing how to configure IP Helper on a Cisco 7600 series router to distribute network configurations settings to multiple subnets in Brocade’s VCS® Fabric with Brocade VDX Switches.

 

Contents

 

Preface

Overview

Configuring IP Helper on a Cisco 7600 router for use with Brocade's VCS® Fabric and Brocade VDX® Switches is easily done. Virtual IP interfaces (VE) in the VCS Fabric forward VLANs to the IP helper address. This is a proven method to support DHCP services for clients in multiple subnets via a Cisco 7600 router configured with IP Helper.

Dynamic Host Configuration Protocol (DHCP) automates the assignment of IP addressing and network configuration to end devices in a network. A DHCP server assigns IP addresses and any additional networking configuration parameters to the DHCP clients.

The protocol relies on broadcasts. The first time a client requests an IP address from a DHCP server, it uses broadcasts with the message exchange in the following way:

  • A client sends a broadcast query (DHCP Discover) to find a DHCP server so it can receive a lease for an IP address.
  • The DHCP server replies with a broadcast (DHCP Offer) containing the IP address and any additional network parameters
  • The client responds back to the DHCP server with a broadcast message (DHCP Request) to request an IP offered from the DHCP server –while responding back to the DHCP server with a broadcast message
  • Finally the DHCP server broadcasts an acknowledge (DHCP ACK) back to the client confirming the client can use the requested IP address.
  • Normally the DHCP server is on the same subnet so it can respond to broadcast queries from clients.

Instead of deploying a DHCP server on every VLAN where dynamic IP configuration is needed, a special router configuration can be used to relay DHCP requests from clients on one subnet to a server on another subnet.  This is called IP Helper.

IP Helper on the Cisco 7600 router receives host broadcasts for a DHCP server on UDP port 67 on all router ports configured with IP Helper. It unicasts the requests on the DHCP server subnet. The DHCP server responds with a unicast reply to the router containing network configuration information appropriate for the host and it’s subnet. Then, the router unicasts that information to the host. The DHCP Request and DHCP ACK messages are also relayed through IP Helper.

 

About Brocade

Brocade® (NASDAQ: BRCD) networking solutions help the world’s leading organizations transition smoothly to a world where applications and information reside anywhere. This vision is designed to deliver key business benefits such as unmatched simplicity, non-stop networking, application optimization, and investment protection.

Innovative Ethernet and storage networking solutions for data center, campus, and service provider networks help reduce complexity and cost while enabling virtualization and cloud computing to increase business agility.

To help ensure a complete solution, Brocade partners with world-class IT companies and provides comprehensive education, support, and professional services offerings. (www.brocade.com)

 

Key Contributors

The content in this guide was developed by the following key contributors.

  • Lead Designer:          Jeffrey Rametta, Strategic Solutions Lab

 

Document History

Date                  Version        Description

2013-04-03         1.0               Initial Release

 

Example Configuration

In the example configuration, IP Helper is running on a Cisco 7600 router connected to a VCS Fabric of VDX Switches.

IPHelper_ExampleConfiguration.jpg 

   Example Configuration

IP Helper is configured on the Cisco 7600 router for all VLANs that contain DHCP clients (hosts). The DHCP server’s IP address is defined with the ip helper-address command.

----------

interface Vlan2000

ip address 192.168.75.250 255.255.255.0

ip helper-address 192.168.85.2 <- DHCP Server IP Address

!

interface Vlan2001

ip address 192.168.76.250 255.255.255.0

ip helper-address 192.168.85.2

!

----------

The DHCP server can be on another VLAN with a virtual IP address

----------

interface Vlan1000

ip address 192.168.85.1 255.255.255.0

!

----------

Broadcast DHCP requests from clients on VLAN 2000 are forwarded to the IP Helper address using the virtual IP address of the VLAN.  The DHCP server responds and the Cisco 7600 router forwards the packets to the DHCP client (host).

A typical DHCP server configuration would like similar to this:

----------

# /etc/dhcpd.conf on server 192.168.85.2

default-lease-time 600;

max-lease-time 7200;

option domain-name-servers 192.168.1.1, 192.168.1.2;

option domain-name "mydomain.example";

subnet 192.168.75.0 netmask 255.255.255.0 {

option subnet-mask 255.255.255.0;

option broadcast-address 192.168.75.255;

option routers 192.168.75.1;

range 192.168.75.10 192.168.75.100;

}

subnet 192.168.76.0 netmask 255.255.255.0 {

option subnet-mask 255.255.255.0;

option broadcast-address 192.168.76.255;

option routers 192.168.76.1;

range 192.168.76.10 192.168.76.100;

}

----------

The router IP address specified in the dhcpd.conf file is the default gateway address for the hosts in each VLAN.  In a VCS Fabric, the default gateway address is the virtual IP (VIP) addresses defined in the VRRP-E configuration for two VDX Switches, RBridge ID 100 and 101, as shown below.

----------

rbridge-id 100

ip route 0.0.0.0/0 10.17.80.1

protocol vrrp

linecard 3 LC48x1G

linecard 4 LC48x10G

interface Ve 2000

  ip mtu 1500

  ip proxy-arp

  ip address 192.168.75.254/24

  no shutdown

  vrrp-extended-group 20

   virtual-ip 192.168.75.1

   enable

   no preempt-mode

   advertise-backup

short-path-forwarding

  !

!

interface Ve 2001

  ip mtu 1500

  ip proxy-arp

  ip address 192.168.76.253/24

  no shutdown

  vrrp-extended-group 21

   virtual-ip 192.168.76.1

   enable

   no preempt-mode

   advertise-backup

short-path-forwarding

  !

----------

When a host in any VLAN in the VCS Fabric connects to the fabric, it receives an IP address and configuration settings from the remote DHCP server as shown below.

----------

Mar 15 18:37:17 centos1 kernel: ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready

Mar 15 18:37:20 centos1 dhclient: DHCPREQUEST on eth2 to 255.255.255.255 port 67 (xid=0x1e7e2839)

Mar 15 18:37:20 centos1 dhclient: DHCPACK from 192.168.76.250 (xid=0x1e7e2839)

Mar 15 18:37:21 centos1 NET: /sbin/dhclient-script : updated /etc/resolv.conf

Mar 15 18:37:21 centos1 dhclient: bound to 192.168.76.10

----------

Contributors