Brocade University

Reply
Occasional Contributor
pushker.sahai
Posts: 7
Registered: ‎11-20-2012

brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

Hi,

I am looking for brocade 10g ethernet card drivers for linux kernel 3.6.6-1.el6xen.x86_64.

The present drivers available for download are for 2.x.x kernel, can someone please point me to right direction on this.

Thanks.

Regular Contributor
Joe.Cannata
Posts: 360
Registered: ‎03-05-2009

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

Where did you get the original drivers? I can try to help you. A URL would be great information.

Joe Cannata
Sr. Manager of Certification
Occasional Contributor
pushker.sahai
Posts: 7
Registered: ‎11-20-2012

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

Hi Joe,

the current drivers are available on Brocade website for download

brocade.com/services-support/drivers-downloads/adapters/Linux.page#Drivers

Thanks.

Regular Contributor
Joe.Cannata
Posts: 360
Registered: ‎03-05-2009

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

So you found them? I discovered the same URL you did. Will what is there work for you?http://www.brocade.com/services-support/drivers-downloads/adapters/Linux.page

Joe Cannata
Sr. Manager of Certification
Occasional Contributor
pushker.sahai
Posts: 7
Registered: ‎11-20-2012

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

But these are for kernel version 2.6, I am not able to find anything  for kernel version 3.6. Thanks.

Regular Contributor
Joe.Cannata
Posts: 360
Registered: ‎03-05-2009

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

Have you tried contacting Brocade Support?

Joe Cannata
Sr. Manager of Certification
Occasional Contributor
pushker.sahai
Posts: 7
Registered: ‎11-20-2012

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

No, not yet. Do I would have to call the customer support number.

I have never dealt with Brocade support before. Thanks

Regular Contributor
Joe.Cannata
Posts: 360
Registered: ‎03-05-2009

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

Yes, call that number and give them your contract information. They will guide you through what they require.

Joe Cannata
Sr. Manager of Certification
Regular Contributor
Joe.Cannata
Posts: 360
Registered: ‎03-05-2009

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

Here is an update:

The 3.6.6 upstream kernel has 3.0.23.0 inbox drivers.  These drivers support Brocade 1010, 1020, 1007 and 1741 adapters.The Brocade driver for Brocade 1860 on 3.6.6 linux kernel, will be release 3.2.0.0 available 3rd or 4th week of December on Brocade.com

Joe Cannata
Sr. Manager of Certification
Occasional Contributor
pushker.sahai
Posts: 7
Registered: ‎11-20-2012

Re: brocade drivers for linux kernel 3.6.6-1.el6xen.x86_64

Hi Joe,

Thanks for your reply.
I found that that we are running Brocade 1010,1020,1007 and 1741 adapters so I downloaded “
Linux Adapter Firmware package for 3.0.23.x Drivers in RHEL 6.4

  <http://www.brocade.com/forms/getFile?p=documents/downloads/HBA/Linux/Drivers/NOARCH/bfa_fw_update_to...> (bfa_fw_update_to_v3.0.23.0.tgz, 827 KB)”

But this tar file has only 3 bin files, I can not execute these bin files

# ./ctfw-3.0.3.1.bin
-bash: ./ctfw-3.0.3.1.bin: cannot execute binary file
# ./ct2fw-3.0.3.1.bin
-bash: ./ct2fw-3.0.3.1.bin: cannot execute binary file
# ./cbfw-3.0.3.1.bin --help
-bash: ./cbfw-3.0.3.1.bin: cannot execute binary file

How can I install drivers from these? Please let me know.

Thanks,
Pushker

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.